When you have a large amount of data and you need to get summary information and graph it, the PivotTable and PivotChart tools in Microsoft Excel will be the answer. The data does not need to be in one workbook. You may analyze data from multiple workbooks without too much trouble.

**Basics of PivotTables**

PivotTables allow you to consolidate large amounts of data with similar fields and analyze the consolidated data or just summarize the consolidated data. The PivotTable tool in Excel gives you an easy way to create a PivotTable for your data. Please note that the data must have at least 1 field in common otherwise, the consolidation will not work and spelling errors in the data will produce incorrect PivotTables.

**Basics of Charts**

Charts are used to graphically represent data. The PivotChart tool in Excel provides a simple way to create a PivotTable and an accompanying chart. Remember, a chart is only as good as the data or the summary table (PivotTable). If you try to cram too many fields into a chart, you will end up with a non-informative chart. You want to keep it simple and informative. See the examples below:

Informative chart
We will be using the data from the Microsoft sample company Northwind Traders. I exported the orders that Northwind Traders fulfilled over three years. The data is in one Excel worksheet. We are going to create a PivotTable and accompanying chart to see how Northwind Traders are doing.

**Exercise 1: How is Business? – Creating a PivotTable and PivotChart**

1. Open the Northwind_Sample.xls workbook.
2. You should see only one worksheet in this workbook. The worksheet’s name is **Warehouse Orders**.
3. Go to the Insert tab on the ribbon.
4. Look for the Tables group, and select PivotTable. Choose PivotChart from the drop-down options.
5. You should now see the Create PivotTable with PivotChart dialog box.
6. There are a couple of things you’ll need to define in order to create your PivotTable. First, you need to tell Excel from where to get the data. In the **Choose the data you want to analyze** section of the dialog box, you will define where Excel is going to get the data for the PivotTable. Since the data for this example is within the workbook, we will choose **Select a table or range**. Under **Table/Range**, Excel might be smart enough to automatically select the proper range of data from the worksheet. If it does not, click on the little button on the right of the range box. Select the range of data. In the example, we have data in cells A1 to F2156. This means that we have selected six columns (A through F) and 2156 rows.

7. In the **Choose where you want the PivotTable and PivotChart to be placed** section of the dialog box, you can choose to either create the PivotTable and accompanying PivotChart on a new worksheet in the Excel workbook, or you can place both on the current worksheet. For this exercise, we will choose to create a new worksheet for the PivotTable and PivotChart. To do this, select **New Worksheet**. Click **OK**. You should now be taken to the new worksheet.
8. While on the new worksheet, you should see four new tabs on the ribbon: Design, Layout, Format, and Analyze. You should also see the PivotTable Field List and the PivotChart Filter Pane, though we will only be using the PivotTable Field List for this exercise (if you don’t see the panes, click on the Analyze tab in the ribbon, and, in the Show/Hide group, make sure that at least Field List is selected).

9. You now need to set up the PivotTable so that you can get the data summary you desire. The new tabs, as well as the two panes, will be used to help format your PivotTable and PivotChart to do the necessary analysis. For this exercise, let’s see the total number of products sold by category. In the PivotTable Field List, select Quantity and Category to add to the PivotTable report. You should see the PivotTable and PivotChart update appropriately.
10. You should now see **Category** listed under the **Axis Fields** area and **Sum of Quantity** under **Values**. In this case, this is what we want to analyze in our PivotTable.

You can use different functions on the field placed under **Values**. For example, if you wanted to see average quantity for each category, you would click on **Sum of Quantity** and choose **Value Field Settings**. In the **Value Field Settings** dialog box, you can choose the **Average** function to apply to the **Quantity** values. A number of other functions are available here to use in your PivotTable. You may also select different number formatting by clicking on the **Number Format** button and making a selection from the list.

We can see from the chart that Northwind Traders are not doing badly in sales.

What if the chart is ugly or not in the format that you want? Excel makes it very easy for you to format the chart. We will do some simple formatting.

**Exercise 2: Format the Chart Axis**

1. We want the number values on the vertical axis to have a comma to denote thousands. To do this, go to the **Layout** tab on the ribbon. Under the **Axes** group, click on **Axes**, then select **Primary Vertical Axis**, and choose **More Primary Vertical Axis Options**. This will bring up the **Format Axis** dialog box. Select **Number** on the left side tool bar and under **Category** select **Number**. Make sure the **Use 1000 Separator (,)** option is checked. Also, be sure that the **Decimal places** value is “0”.

2. Since none of the values in the PivotChart are greater than 10,000, we want the highest number on our axis to be 10,000, and not 12,000. Click on **Axis Options**. The **Maximum** option is set to **Auto**, which means that Excel has automatically set the maximum value for the axis. To manually specify a maximum value, select **Fixed**. In the box, type in 10000.

3. Click on Close.

4. You will see that the chart has updated automatically with the formatting changes that were just specified.
What if the final results for the PivotTable and PivotChart are not what we expected to see? What should you do? First, check the data and make sure that you are choosing the correct fields. Second, add or remove the fields that you see displayed in the PivotTable. The PivotChart is tied directly to the PivotTable, so the changes that you make in the PivotTable will automatically be reflected in the PivotChart.

You can make other changes to the PivotChart as well, such as changing the title, modifying the horizontal axis labels, or even changing the type of chart that is used. Making these changes to the chart will be covered later.

**Exercise 3: What if…? – Changing the PivotTable**
1. What if we see that the Category field values are not descriptive enough? The Description field values seem better, so we want to use those and not the Category field values. To change this, go to the PivotTable Field List.
2. Uncheck Category in the list and check Description instead.
3. You should see the PivotTable and PivotChart update automatically.

The PivotTable and PivotChart are now providing us some useful information. There is one thing missing, however. We do not know which product is the best seller for each description. If we add the Product Name field into the PivotTable’s Axis Fields, we will end up with a very messy chart. How can we produce a chart that summarizes the data nicely? This is a perfect time to use the Report Filter area.

**Exercise 4: How good are the products selling? – Using a Report Filter**
1. We want to put the Product Name field in the Axis Fields area, and then move the Description field into the Report Filter area. To do this, make sure that both Product Name and Description are selected in the Choose fields to add to report area of the PivotTable Field List.
2. You should now see both Description and Product Name in the Axis Fields area. Click and drag Description into the Report Filter area.
3. Now, look at the PivotChart. All of the Product Name values are shown, so it’s quite hard to read and not very informative.
4. Go to the PivotChart Filter Pane and click on the arrow next to Description under Report Filter. You will see a selection box appear with all of the different Description field values listed. By default, All will be selected.

5. Using this pick list, you can select a specific Description field value, and only the Product Name field values associated with the Description field value picked will be used in the PivotChart. You should see the PivotTable automatically adjust, as well. For this exercise, select Cheeses from the list.

6. Click on OK.

7. You will see that only the Cheese products are displayed in the PivotTable and on the PivotChart.

8. Repeat Steps 5-6 but select Seaweed and fish instead of Cheeses.

We have use a PivotTable and PivotChart on data from a single file source. Now, we will do a PivotTable from multiple workbooks and consolidate the information into a summary worksheet. We have three workbooks – Northwind_Order-1996.xls, Northwind_Orders-1997.xls, and Northwind_Orders-1998.xls. The workbooks have the same fields but each workbook holds the order data for the specified year.

We do not need to copy the worksheets into a single workbook. We can tell Excel to go to those workbooks and grab the data that we need to use. We do need to have the workbooks open.

**Exercise 5: How is Business? – Creating a PivotTable from Multiple Ranges**

We are going to repeat Exercise 1, but this time the PivotTable will use data from three worksheets instead of just one.

2. Open a new, blank workbook.
3. Hit the Alt key, then the D key, and then the P key to open up the PivotTable and PivotChart Wizard.
4. In Step 1 of the wizard, select Multiple consolidation ranges and PivotChart report (with PivotTable report). Click on Next.
5. In Step 2a, you are being asked to set up page fields. Page field is the previous Microsoft terminology used for report filter, so this step is essentially asking you if you want to setup report filters yourself, or if you would like Excel to automatically create report filters. Select Create a single page field for me, as Excel will create a filter for each of the three data ranges we are consolidating into this PivotTable. Click Next.
6. In Step 2b, you will need to define the ranges to analyze. Use the button on the right of the Range box to select the ranges.

7. When the window shrinks, you may select the first workbook and the range. Click on the Northwind_Orders-1998.xls workbook that was opened and select cell A1 on the Orders 1998 worksheet. Type a colon (";") after $A$1. You should see another $A$1 automatically come up after the colon.
8. Delete the second $A$1 and replace it with $JS692$. Don’t use the arrow keys to move your cursor in the text box, or you will have to repeat Step 7 again, since the cells selected on the worksheet will change. Click on the button to the right of the text box to go back to the range selection box. Here you need to click the Add button. The range should now appear in the All ranges box.


10. After you are done, your range selection box should look something like the following:
11. Click Next.
12. Select New worksheet from Step 3 of the PivotTable and PivotChart Wizard, and then click on Finish.

Excel will automatically create the PivotTable and corresponding PivotChart.

Unfortunately, you should see that both the PivotTable, and resulting PivotChart, don’t provide us with any useful information. The problem here is that we have tried to incorporate too much information into our PivotTable. We need to narrow down the data fields, so that we can get a more meaningful analysis.
Let us consider for a second what we are hoping to analyze with our PivotTable. We previously used the PivotTable to look at the quantity of orders for various products, and here we wanted to do the same thing, except using data for three different years. Thus, we only need the quantity of orders and the product name or category from our data. The fields we want need to be together on each worksheet, so that we can specify a range to Excel. It is most convenient if the fields you want line up starting in Column A. Taking a look at our Northwind_Orders-1996.xls, Northwind_Orders-1997.xls, and Northwind_Orders-1998.xls files, you can see that CategoryName and Quantity are already the first two columns, so all we need to do is specify our range to only include these first two columns, and we should be able to come up with a better PivotTable.

**Exercise 6: How is Business? – Creating a Better PivotTable from Multiple Ranges**

2. Open a new, blank workbook.
3. Hit the Alt key, then the D key, and then the P key to open up the PivotTable and PivotChart Wizard.
4. In Step 1 of the wizard, select Multiple consolidation ranges and PivotChart report (with PivotTable report). Click on Next.
5. In Step 2a, you are being asked to set up page fields. Page field is the previous Microsoft terminology used for report filter, so this step is essentially asking you if you want to setup report filters yourself, or if you would like Excel to automatically create report filters. Select Create a single page field for me, as Excel will create a filter for each of the three data ranges we are consolidating into this PivotTable. Click Next.
6. In Step 2b, you will need to define the ranges to analyze. Use the button on the right of the Range box to select the ranges.
7. When the window shrinks, you may select the first workbook and the range. Click on the Northwind_Orders-1998.xls workbook that was opened and select cell $A$1 on the Orders 1998 worksheet. Type a colon (" : ") after $A$1. You should see another $A$1 automatically come up after the colon.
8. Delete the second $A$1 and replace it with SBS692. Don’t use the arrow keys to move your cursor in the text box, or you will have to repeat Step 7 again, since the cells selected on the worksheet will change. Click on the button to the right of the text box to go back to the range selection box. Here you need to click the Add button. The range should now appear in the All ranges box.
10. After you are done, your range selection box should look something like the following:

![PivotTable and PivotChart Wizard - Step 2b of 3](image)

11. Click Next.
12. Select New worksheet from Step 3 of the PivotTable and PivotChart Wizard, and then click on Finish.

The PivotTable and PivotChart generated by Excel should now be a better analysis of the data. You will notice that the PivotTable contains two columns that appear redundant. This is because we have defined only one axis field (CategoryName) and one data field (Quantity) in our data ranges. When the PivotTable and PivotChart Wizard automatically constructs a PivotTable from multiple consolidation ranges, the PivotTable will include both a Row and Column field value. In this case, the Row field value corresponds to CategoryName, but we really don’t need a Column field. So, we can remove this field from our PivotTable.
13. Go to the PivotTable Field List. Under Choose fields to add to report, uncheck Column. You should see the redundant column in the PivotTable disappear.

Tips for Charts

- Charts should be simple and represent the data clearly and accurately. It is easy for a chart to be misleading, so be careful.
- There are many different kinds of charts, and Excel gives you a wide variety of chart types from which to choose. However, you need to be careful when choosing the chart type to use. Some chart types are appropriate for displaying some types of data, but not others. For example, if you are comparing the number of apples sold versus the monthly cost of running a farm, a pie chart is not a good chart type to use because you are graphing two factors across a third factor (time). The line chart would be a better choice.
You can change the PivotChart to use any chart type offered by Excel. In the ribbon, click on the Design tab, and then select Change Chart Type from the Type group.

Below is an example of the PivotChart for Exercise 6 using a pie chart type.

In Exercise 2, we were introduced to some simple formatting that can be done to the axis of a PivotChart. In the previous section, we were also shown how easy it is to change the chart type for a PivotChart. Formatting changes are not just limited to these two aspects of the PivotChart. In the next section, we’ll also explore some other customizations that can be used for a PivotChart that you may find useful.
The exercise below will be utilizing the same workbook and PivotChart from Exercise 6.

**Exercise 7: Customizing a PivotChart**

1. Go to the worksheet containing the PivotChart, and select the PivotChart. You should be able to see the Design, Layout, Format, and Analyze tabs on the ribbon.
2. Click on the Design tab, and select Change Chart Type from the Type group. Select the 3-D Column chart.

3. You should see the PivotChart automatically update using the new chart type.
4. Update the title on the chart by clicking on the chart title, and the replacing the current title of Total with Northwind Orders.

![Northwind Orders Chart](image)

5. You can show the numeric values that each column represents above the respective column by showing the data labels. To do this, go to the Layout tab on the ribbon, select Data Labels from the Labels group, and then choose Show.
6. Finally, change the color of the columns of the chart. To do this, first click on one of the columns within the PivotChart. Then, go to the **Format** tab on the ribbon, select **Shape Fill** from the **Shape Styles** group, and choose the color you desire. For the purpose of this exercise, let’s choose **Red**.

7. Your PivotChart should now look similar to the one below.