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Introduction

This document is an introduction to Firefox 2.0, and is written for the University of Hawai‘i (UH) user
with a Macintosh personal computer running OS X. Firefox is a free web-browsing program distributed
by Mozilla.

System Requirements

System requirements for Firefox 2.0 can be found online at http://www.hawaii.edu/askus/784. Also, be
sure to check the browser recommendations page for ITS supported web applications at
http://www.hawaii.edu/askus/717 to verify that Firefox will work with any of the web applications you
use.

Where to Get It

You can download the current ITS-supported version of Firefox at http://www.hawaii.edu/askus/575.
Alternatively, you can download the latest version of Firefox from the Mozilla web site at
http://www.mozilla.com. Note that this version may differ from the ITS-supported version.
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Installation

Once you have downloaded the Firefox installer to your Macintosh, you can install it by following the
instructions below.

1.

2.

Close any older versions of Firefox if you have any installed.

Double-click the installer on your desktop to install.

Read and Accept the license agreement that appears on the first screen.

Copy the Firefox application icon to your hard drive by clicking and dragging it to the Applications
folder on your computer’s hard drive.

22 X&)

& Firefox

LS

1 item, Zero KB available

Firefox

Firefox 2.0 is now installed on your computer. If you already had a dock icon for an older version of
Firefox, it should be updated to Firefox 2.0. You can also create a new shortcut to Firefox 2.0 on your

dock at this time by dragging the Firefox icon from Applications folder to your dock.
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Configuring Firefox

1. To launch Firefox, click on the Firefox icon that is in the dock or open it from within the
Applications folder.

2. Upon launch for the first time, Firefox will ask if you want to import preferences, bookmarks, history,
passwords and other data from other applications. If you wish to import Settings and Data, choose an
application and then click Continue. If the Import Wizard does not open and you wish to import
information, you can get to it under the File menu after opening Firefox.

ean Import Wizard

==
Import Settings and Data @

Import Preferences, Bookmarks, History, Passwords and other data
from:

@ Safari

:; Microsoft Internet Explorer

P .
) Netscape &, 7 or Mozilla 1.x

[ Cancel /'J Co Back - Continue

3. Select the items to be imported. Click on Continue.

@60  ImportwWizad

Items to Import @

Sgle_ct whic_h items to import:
E Preferences

@ Cookies

@ Browsing History

@ Bookmarks

{ Cancel JI { Co Back I ( Continue )

L
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The following screen reports the results of the import. Click on Done.

8ean Import Wizard

Import Complete a

The following items were successfully imported:
Preferences
Cookies
Browsing History
Bookmarks

Using Firefox

To launch Firefox, click on the Firefox icon that is in the dock or open it from within the Applications
Folder. The application will open to your configured Home Page. If you have not designated a Home

Page of your own, the application will start with the default Firefox start page.

qQ
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This screen is broken out into sections.

|6 06 Mozilla Firefox Start Page (2] |

The top bar has three circle shaped buttons on the top left corner and one on the right corner. The red
button closes the current window, but not the entire application. The yellow button minimizes the current
window to your dock and the green button maximizes the window size. The gray button on the right side
toggles between a full screen browser mode that removes the other toolbars and one with the toolbars.

| all v (’J /;" |G_http | {www.google.com /firefoxclient=firefox-a&rls=org.mozilla:en-Us: official v P |C} ¥ Q |

The toolbar under the previous one is called the Navigation Toolbar. You can choose to show or not to
show this toolbar by going to View > Toolbars and either selecting or unselecting this toolbar (the check
next to the toolbar name means it has been selected). From left to right this toolbar includes:

Back button — This button takes you back to previous pages you have visited. You
oy can get a list of these pages by clicking on the arrow next to the button. If you have
not visited any pages yet, this button is gray.

Forward button — If you click the back arrow to return to previous pages, this
w . .
= button turns green, allowing you to move forward. You can list the pages to move
forward to by clicking on the arrow next to this button.

| Reload Current Page button — You can use this button to reload the page you are
( viewing to check for updates or changes to it. You can also use this button if the
current page is not displaying properly.

Stop Loading Page button — This button is only active (bright red) when a page is
trying to load. You can stop the page from loading if you click this button.

#™_ Home button — Clicking on this button will return you to the Home Page that you
| have setup in Firefox.

|{:1 http: / f'www.google.com/firefox?client=firefox-a&rls=org.mozilla:en-U5: official ¥ B

The Address Bar is where you type in the URL (web page address) or file name to which you would like
to navigate. Clicking on the arrow shows the web sites you have previously visited. Once you type in the
URL, you can either hit the return key or click the green arrow on the right of the toolbar to go to that

page.
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The Search Bar is where you can use your favorite search engine without having to navigate to the
search engine’s web site. The default search engine is Google, but you change it to others, such as
Amazon or Yahoo. You can also download other search engines.

Getting Started  Latest Headlines®  Currents News AppleY News¥ MyUH Portal

The next toolbar down is the Bookmark Bar. You can add bookmarks to web sites that you visit
frequently through this toolbar. You can add bookmarks by dragging the image next to the URL to this
bar, or by editing it under the Bookmarks menu. This toolbar is also where you can read RSS feeds.
Bookmarks that include RSS feeds are marked with an orange icon. You can also choose not to view this
toolbar by unselecting it under View > Toolbars.

|Done myuhportal hawaiiedu & g Open Notebaok |

At the bottom of the page there is the Status Bar. The bottom left side shows you the status of a page that
is loading. The bottom right side shows you the site you are viewing and whether it is a secure page or
not. A secure page shows a lock. Pages that are not secure do not show this lock. If you install extensions,
such as the Google Notebook, they will also show up here for quick access.

Now that you are familiar with the main Firefox screen, there are many preferences that you can
customize in Firefox. To change various options in Firefox, go to Firefox > Preferences.
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Main is where you can set the Home Page, which is the page that Firefox opens automatically when it
starts. You can also change how Firefox behaves for file downloads, as well as set Firefox to check to see

if it is the default web browser for your computer when it starts up.

enn Main [=)

f N & 5L
el @ B & & @

Main Tabs Content Feeds Privacy Security Advanced

Startup

When Firefox starts: = Show my home page .]

Home Page:  http:/ fwww.hawaii.edu/its

( Use Current Page ) ( Use Bookmark ) ( Restore to Default )

Downloads
8 Show the Downloads window when downloading a file

"I Close it when all downloads are finished

T

® Save files to @ Desktop ( Choose... )

C Always ask me where to save files
System Defaults

] Always check to see if Firefox is the default browser on startup (" Check Now )

]
)

Under Tabs, you can determine whether or not to use tabbed browsing in Firefox. You can also manage

the behavior of the tabs.

e Tabs

W@ e & ©

Main | Tabs Content Feeds Privacy Security Adwvanced

New pages should be opened in:
() a new window
@ a new tab

EWam me when closing multiple tabs
™ Warn me when opening multiple tabs might slow down Firefox
[ Always show the tab bar

[1When | open a link in a new tab, switch to it immediately
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Content is where you can set various content-related options, such as blocking pop-up windows, loading
images on web pages, using Java and JavaScript, setting default fonts and colors for Firefox to use, and
setting up how Firefox handles certain file types. For example, you can choose to have .pdf files open

with Adobe Acrobat instead of Preview.

POOE Content

Main Tabs  Content Feeds Privacy Security Adwvanced
™ Block pop-up windows
™ Load images automatically

@ Enable JavaScript

E Enable Java

Fonts & Colors

r'd - ™\
( Exceptions... )
. ———

r'd N Y
[ Exceptions...
.

(" Advanced... )

|

Default font: | Times |:] Size: |16 | %

~] ( Advanced... )

File Types

Configure how Firefox handles certain types of files

T ——
[ Colors... )
bl

( Manage... )

Feeds is where you can set the behavior for how various RSS feeds are handled. By default, they are

viewed in the Live Reader on the Bookmark Bar.

666 Feeds

a ' ) ] [
e 7 @ & B W&

Main Tabs Content @ Feeds Privacy Security Advanced

When | click on a web feed:
@ Show me a preview and ask me which Feed Reader to use
() Subscribe to the feed using:

|5 Live Bookmarks

No Application Selected
[:] Bloglines

¥? My Yahoo

Google

Choose Application...
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Privacy is where you will find the privacy settings for Firefox. This is where you can change the

behavior of browser history, cookies, and private data (such as saved passwords). Here, you can set your
private data to be cleared every time you close Firefox.

laNaNa]

Privacy

(==
@ ReE & @

S
Main Tabs Content Feeds

Privacy = Security Advanced
History

™ Remember visited pages for the last 9 days.
gkemember what | enter in forms and the search bar
8 Remember what I've downloaded

Cookies

gAccept cookies from sites

Fa

Exceptions... b

Keep until: [ they expire | ‘]

Fa

( Show Cookies... )

Private Data

"] Always clear my private data when | close Firefox ( Settings... 3
2R

@Ask me before clearing private data (" Clear Now... )
.~ —— S
)

L

Under Security, you can manage warning messages that Firefox uses, particularly when installing add-
ons or visiting sites that may not be safe. You can also manage saved web site passwords.

00 Security (=)
] me Y = [y

e @R e & @

Main Tabs Content Feeds

Privacy | Security Advanced

@Wam me when sites try to install add-ons € Exceptions... 3
N T S
ETeII me if the site I'm visiting is a suspected forgery

® Check using a downloaded list of suspected sites
(0 Check by asking = Google | :] about each site | visit

Passwords

8 Remember passwords for sites

Vs

—
Exceptions... )
] Use a master password

Change Master Password...
(" Show Passwords... )

Warning Messages

Choose which warning messages you want to see while browsing the web (* Settings... 3

—— = S

iy
=)
hZ/
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Advanced is where you can set other preferences for Firefox. There are several tabs under Advanced.

e @ B & & ©

Main Tabs Content Feeds Privacy Security Advanced

[ General || Network I’ Update 1‘ Encryption I

Automatically check for updates to:
!E Firefox

# Installed Add-ons
# Search Engines

When updates to Firefox are found:
") Ask me what | want to do
f®) Automatically download and install the update

™ Warn me if this will disable any of my add-ons

(_ Show Update History |

e The General tab contains some options relating to the general use of Firefox while browsing different
web pages. The options include accessibility and language options.

e The Network tab contains network settings that Firefox will use, including proxy settings and cache
options.

o The Update tab contains options relating to what updates you would like Firefox to check for over
the Internet. Firefox can automatically check for updates for the core web browser, as well as for any
installed add-ons. If you would like this feature disabled, you may uncheck these check boxes. Under
this tab, you can also configure how Firefox handles these updates when installing them.

e The Encryption tab contains options for what encryption Firefox can use when encountering secure
web sites, and also how to proceed with security certificates that the browser encounters.

For more information on the above options, please refer to the help file within Firefox by selecting
Firefox Help from the Help menu.
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Quitting Firefox

When you are finished with Firefox, you can exit the application by going to Firefox and selecting Quit
Firefox.

Uninstalling Firefox

You can uninstall Firefox from your hard drive by dragging the shortcut out of the dock, and dragging the
Firefox application out of the Applications folder and into the Trash. Firefox cannot be open on your
computer when you are doing this.

More Information

For more information on Firefox 2.0, you can visit the following web sites:

e ITS AskUs article on Firefox — http://www.hawaii.edu/askus/784
e Mozilla Firefox web site — http://www.mozilla.com/en-US/firefox/

Getting Help

For additional assistance, please phone the ITS Help Desk at (808) 956-8883,
send email to help@hawaii . edu, or fax (808) 956-2108.
Neighbor islands may call the ITS Help Desk’s toll-free phone number at (800) 558-2669.

Or see the ITS web site at http://www.hawaii.edu/its
The ITS walk-in Help Desks are located in
Keller 105, Keller 213, the Sinclair CLIC Lab, and the ITS Hamilton Lab on the UH Manoa Campus.

The University of Hawai‘i is an equal opportunity/affirmative action institution.

Getting Started with Firefox 2.0 MAC1029 Page 11


http://www.hawaii.edu/askus/784
http://www.mozilla.com/en-US/firefox/

	Introduction 
	System Requirements 
	Where to Get It 
	Installation 
	Configuring Firefox 
	Using Firefox 
	Quitting Firefox 
	Uninstalling Firefox 
	More Information 
	Getting Help 

