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Introduction 
 
University of Hawai‘i (UH) Procedures Business Circular 835 essentially states that all information on 
the letterheads, envelopes and business cards (with the exception of the UH seal) will include the 
appropriate Hawaiian diacritical marks. 
 
The ‘okina or glottal stop is the open typesetter’s quote (‘) and can be done quite easily from all 
Macintosh applications as it is part of the standard character set of most fonts.  However, the kahak  or 
macron (¯) is not part of the standard character set and isn’t easily created in any application. 
 
This document is an aid for those of you who need to create these diacritical markings without any 
additional purchases such as other fonts or font editor programs.  It concentrates on MS Word for the 
Macintosh.  (Windows users can refer to the document Hawaiian Diacritics and MS Word, available at 
http://www.hawaii.edu/itsdocs/win/diacritics.pdf). 
 
 

Creating the ‘okina 
 
This is the ‘okina:  ‘ 
Notice that it looks like a 6.  It is not this:  ’ or this:  `  although you may have seen those characters used.  
The correct way to represent the ‘okina is:  ‘ 
 
This method for creating the ‘okina should work with any font, in all Macintosh applications: 
 
 Press Option-]  (Press the Option key together with the ] key (right bracket key).) 
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Creating the kahak  using field codes 
 
If you do not wish to download and install fonts, you can also use “field codes” to create kahak  vowels.  
You may need to enable the viewing of field codes first. 
 
Enabling Field Codes in Word X or 2004 
 
Go to the Word menu and select Preferences...  On the left side, click on View.  Make sure the box 
next to the Field Codes option is checked.  Click on OK. 
 
Enabling Field Codes in Word 98 or 2001 
 
Go to the Tools menu and choose Preferences...  Click on the View tab.  Make sure the box next to 
the Field Codes option is checked.  Click on OK.  This allows you to view the Field Codes that you 
create. 
 
Once you’ve enabled the viewing of field codes, here’s an example of using a field code to create an : 
 
1. Press Command-F9 (the command key is the Apple key) 
 This will create something that looks like this: {  } 
 This is the field code symbol. 
 
 You can also go to the Insert menu and choose Field.  In the Categories column, click on 

Equations and Formulas.  In the Field Names column, click on Eq.  Click on OK.  This will create 
something that looks like this:  { EQ } 

 
 Delete everything within the curly brackets, including spaces. 
 
2. Type eq \o(a,  
 The slash in the above formula is the regular backslash. 
 
3. Press Shift-Option-, (Creates the kahak  character) 
 
4. Type a ) (right parenthesis) 
 
Your field code should look like this when you are done:  {eq \o(a,¯)} 
 
For example, on screen you would see University of Hawai‘i at M{eq \o(a,¯)}noa. 
 
When you print the document, it will look like:  University of Hawai‘i at Mānoa. 
 
You can use the same formula and change the a to an i, e, o, u, A, E, I, O, or U depending on which vowel 
needs the kahak . 
 
Words containing a kahakö, if they are at the end of a line, will “split” at the kahakö formula.  For 

example, M noa will break right after “M ”.  To avoid this problem, put the entire word into the field 
code as shown below: 
 
 {eq M\o(a,¯)noa} 
 
You may want to type all words that need the kahak  within the field code curly brackets. 
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Depending on the font and/or font size you are using, the kahak  may either print too low or too high over 
the tops of vowels.  You may need to raise or lower the kahak : 
 
1. Highlight the kahak  character in the formula. 
 
2. Go to the Format menu and choose Font.  Click on the Character Spacing tab.  Click on the down 

arrow next to Position (to the right of the word Normal) and choose Raised (or Lowered) from the 
pop up menu.  In the By box, type the amount you wish to raise or lower the kahak  (1 pt, 2 pt, 
etc.).  This value will vary depending on the font you are using.  You may have to try different point 
sizes to find the correct value for your font.  Click on OK when you are finished. 

 
The line spacing in your document may be uneven.  To make it more even, you can do the following: 
 
1. With the blinking cursor (I bar) anywhere in the paragraph, go to the Format menu and choose 

Paragraph. 
 
2. Change the Line Spacing to Exactly, and change the At value to the point size of the text you’re 

using.  Click on OK. 
 
You can preview before printing by going to the File menu and choosing Print Preview.  Your pointer 
should change into a magnifying glass.  Click on the part of the page you want to see. 
 
This method produces acceptable results in most situations, especially if you use kahak  infrequently.  
However, the kahak  will still run into any g’s, j’s, p’s, or y’s that happen to be above it. 
 
AUTOCORRECT FEATURE 
 
AutoCorrect is a feature in Word that can be used to make your ‘okina or kahak  easier to type. 
 
1. Highlight the entire formula (including the curly brackets) if doing a field code or highlight the 

entire word if doing an ‘okina. 
 
2. Go to the Tools menu and choose AutoCorrect. 
 
3. In the Replace box, type the word that will automatically be corrected; for example, you can type in 

Manoa for {eq M\o(a,¯)noa}. 
 
4. Click on Add, then click on OK. 
 
Now, whenever you type the word Manoa in a document, the correctly formatted text will replace it as 
soon as you press the spacebar. 
 
Use this method to create AutoCorrect entries for any other words with ‘okina or kahak  that you might 
need. 
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Creating the kahakö with the ‘Ölelo fonts 
 
There are free fonts that include the kahak  character available for download from the ‘ lelo Web site.  
The available fonts are 
 
 HI Kakuhihewa = Courier 
 HI Manokalanipo = Times 
 HI Pi‘ilani = Palatino 
 HI Keawe = Helvetica 
 
The Information Technology Services (ITS) labs (Keller 105, Keller 213, Hamilton Library, and CLIC) 
have the ‘ lelo fonts installed on the computers there.  The Center for Hawaiian Studies and the 
Hawaiian Language department have also standardized on the ‘ lelo fonts. 
 
INSTALLING THE ‘OLELO FONTS UNDER MAC OS X (WORD X OR 2004): 
 
1. Go to this web page: 
 http://www.olelo.hawaii.edu/eng/resources/mac_fonts.html 
  and click on the link Download HI Macintosh fonts 
 
2. When the download is finished, there will be a file called “mac_fonts.sea” on your desktop.  

Drag/drop this file onto the Stuffit Expander icon to extract.  (Stuffit Expander should be in the 
“Utilities” folder within the “Applications” folder on your hard drive.)  This will put a “mac_fonts 
Folder” on your desktop.  Open this folder, and put the following files into the “Fonts” folder that's 
in the “Library” folder on your hard drive: 

 
 HI Kakuhihewa Fonts 
 HI Keawe Fonts 
 HI Manokalanipo Fonts 
 HI Pi'ilani Fonts 
 
Note: do NOT do anything with the Papa Pihi "HI" file.  In fact, you can delete it, as it was intended for 
Mac OS 9. 
 
3. Go to this web page: 
 http://www.olelo.hawaii.edu/eng/resources/osx/hifonts.html 
 Scroll down the page and click on the link Click here for Papa Pihi HI.rsrc for OS X 
 
4. When the download is finished, there should be a file called “Papa Pihi HI.rsrc” on your desktop.  

Put this file in the “Keyboard Layouts” folder that's in the “Library” folder on your hard drive. 
 
5. Restart the Macintosh. 
 
6. Go to the Apple menu and select System Preferences.  Click on the International icon, then click 

on the Input menu tab.  Check the box next to “Papa Pihi HI”.  You should now see a US flag icon 
in the upper right of your screen, near the time.  Under this flag icon, you can choose between the 
US keyboard and the Papa Pihi keyboard. 
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INSTALLING THE ‘ÖLELO FONTS UNDER MAC OS 9 (WORD 98 OR 2001) 
 
1. Go to http://www.olelo.hawaii.edu.  Click on the K. 
 
2. Scroll all the way down to the bottom of the page and click on Download HI Macintosh Fonts. 
 
3. On the next page, click on either Download HI Macintosh Fonts (HTTP download) or Download 

Macintosh Fonts (FTP download).  It doesn’t matter which one you choose.  Both downloads are 
approximately 385kb. 

 
4. When the download is finished, you should have an icon on your desktop called mac_fonts.sea.  

Double click on this icon.  Click on the Desktop button, then click on Extract. 
 
5. On your desktop, you should now see four font suitcases called HI Kakuhihewa, HI Manokalanipo, 

HI Pi‘ilani, and HI Keawe.  There should also be an icon called Papa Pihi “HI”.  Papa Pihi is a 
special keyboard for use with the ‘ lelo fonts only.  Move the four font suitcases into the Fonts 
folder in your System folder on your hard drive.  Move the Papa Pihi “HI” file into the System 
suitcase in your System folder on your hard drive.  Note that you will have to quit all running 
applications to move the Papa Pihi file. 

 
6. Close all windows and restart your Macintosh. 
 
7. After your Macintosh has finished restarting, go to the Apple menu, then Control Panels, then 

Keyboard.  In the list of keyboard layouts, look for Papa Pihi “HI”, and make sure the box to the 
left is checked.  Close the Keyboard control panel. 

 
USING THE ‘ÖLELO FONTS 
 
To use the ‘ lelo fonts, you need to switch to the Papa Pihi keyboard.  To do this, point and hold down 
the mouse on the U.S. flag symbol in the upper right corner of your screen.  A menu will drop down; 
select Papa Pihi “HI”. 
 
In your document, you need to use one of the four ‘ lelo fonts (HI Kakuhihewa, HI Manokalanipo, HI 
Pi‘ilani, HI Keawe) as your document’s font.  To get the kahak  to appear, type the following keystrokes: 
 
 Option-vowel for a lower case vowel 
 For example, for an , type Option-o 
 
 Shift-Option-vowel for an upper case vowel 
 For example, for an , type Shift-Option-a 
 
For more information about the ‘ lelo fonts, please visit 
 
 http://www.olelo.hawaii.edu 
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Creating the kahak  using the built-in Hawaiian keyboard (OS 10.3 and 
higher) 
 
If you have Mac OS 10.3 or higher, there is a built-in Hawaiian keyboard that you can use to type the 
kahakö.  The built-in Hawaiian keyboard only works with applications and fonts that are “unicode 
compliant”.  Not all applications or fonts are compatible with unicode.  Word 2004 (but not Word X) is 
unicode-compliant, as well as TextEdit. 
 
To enable the built-in Hawaiian keyboard: 
 
1. Go to the Apple menu and select System Preferences 
2. Click on International 
3. Click on Input Menu 
4. Scroll down and check the box next to Hawaiian. 
 
To use the keyboard: 
 
1. Select the Hawaiian keyboard under the flag icon in the upper right of the screen 
2. Press the option key and the vowel.  For an “a” you would press option-a, for an “e” you would 

press option-e, and so forth. 
 
Note: not all fonts will work with this keyboard. 
 
 
Contact Information 
 
If you have any questions regarding Hawaiian diacritics or other solutions not listed in this document, you 
may contact either of the following people: 
 
 Teresa Sakata Phone: 956-2399 e-mail: teresa@hawaii.edu 
 Naomi Okinaga Phone: 956-2398 e-mail: naomi@hawaii.edu 
 
 

 
For additional assistance, please phone the ITS Help Desk at (808) 956-8883,  

send email to help@hawaii.edu, or fax (808) 956-2108. 
Neighbor islands may call the Help Desk’s toll-free phone number at (800) 558-2669. 

 
Or see the ITS Help Desk’s home page at http://www.hawaii.edu/help 

The ITS walk-in Help Desks are located in  
Keller 105, Keller 213, Sinclair 122 (CLIC), and the ITS Hamilton Lab on the UH M noa Campus. 
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